[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Pre-Lock.bat

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Thu, 7 Apr 2011 16:21:06 +0200

On Thu, Apr 7, 2011 at 16:15, Feldhacker, Chris
<Feldhacker.Chris_at_principal.com> wrote:
> When he tries to break a lock via the Repo-Browser it fails with a
> 500 error.
> When he tries to get a lock via the "SVN Get Lock" context menu option it
> correctly reports another user already has the lock.
> When he tries to break a lock via the "SVN Get Lock" context menu and
> chooses the "steal lock" option, then this also works correctly and the lock
> is stolen.
>
> Why would trying to break a lock using the Repo-Browser result in a 500
> error, but doing the same thing via the context menu path work?
>

My psychic powers tell me the reason for that is that the hook script
can't deal with full urls but only with local paths or relative
paths/urls.

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2717686
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-04-07 16:21:36 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.