[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SVN merge dialogue gives no response

From: Simon Large <simon.tortoisesvn_at_gmail.com>
Date: Wed, 24 Nov 2010 12:12:45 +0000

On 23 November 2010 23:21, Phil Parsons <pparsons_at_rogers.com> wrote:
> Hi,
>
> Windows XP Pro SP3 on an Intel Core 2 Duo, 4GB RAM, 320GB HD
> Note that in the following descriptions every install and/or uninstall was
> followed by a reboot ... just to be sure.
>
> I recently upgraded to TortoiseSVN version:
> TortoiseSVN 1.6.11, Build 20210 - 32 Bit , 2010/09/30 20:36:44
> Subversion 1.6.13,
> apr 1.3.8
> apr-utils 1.3.9
> neon 0.29.4
> OpenSSL 0.9.8o 01 Jun 2010
> zlib 1.2.3
>
> and for the first time in a while I went to use the Merge function (merge a
> range of revisions).  I know that since the last time I tried a Merge all
> the repositories have been moved to a different URL but still the same
> repository, and I have rebuilt my system, but not my copies (they have been
> working fine).

If you did not relocate the working copies after the repository moved
then your commits have all been to the old URL.

> The merge dialogue looked like normal, except that the URL
> to merge from dropdown was empty, and the repo-browser button does nothing
> (it depresses ... but nothing) and of course the Revision  Range to Merge
> "Show Log" button does nothing because there is no URL, the working copy
> "Show Log" works fine but isn't much use here unless I wanted to do a
> reverse merge.

The URL is empty because you rebuilt your PC and there is no stored
history. The repo browser doesn't work because it needs a repository
URL to browse within. Browsing a directory for repositories is not
really supported in SVN.

> I thought it was the upgrade, so I reinstalled the previous version
> (1.6.10.19898-win32-svn-1.6.12) and that completely broke all explorer links
> to SVN.  Panic mode ... then I uninstalled both versions (Add/Remove
> programs) and reinstalled the latest 1.6.11 again.  That brought back all
> the functionality that disappeared as described above.  Now I'm left with
> the non-working Merge dialogue, everything is enabled, no error messages and
> no worky ...

Simon

-- 
:       ___
:  oo  // \\      "De Chelonian Mobile"
: (_,\/ \_/ \     TortoiseSVN
:   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
:   /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2685347
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-11-24 13:12:56 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.