[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Broken SNI support in current (1.6.8) TortoiseSVN Release?!

From: Jean-Marc van Leerdam <j.m.van.leerdam_at_gmail.com>
Date: Fri, 4 Jun 2010 10:29:55 +0200

Hi,

On 4 June 2010 08:30, Tobias Jamin <tobias-jamin_at_gmx.de> wrote:
> Hi folks,
>
> I think the SNI support in the current TortoiseSVN Release is broken or something. With TortoiseSVN 1.6.6 everything works fine and I get access to my SVN repositories on my server (Apache 2.2.14 with enabled mod_ssl and enabled SNI support, svn 1.6.6). But with the newest, current TortoiseSVN Release 1.6.8 I get the following error message
>
> Server sent unexpected return value (403 Forbidden) in response to OPTIONS request for 'https://svn.mydomain.com/code'
>
> and on my server Apache logs the following message
>
> [Fri Jun 04 08:23:40 2010] [error] No hostname was provided via SNI for a name based virtual host
>
> Usually apache logs this error message if the requesting HTTPS client does not support SNI. Using Mozilla Firefox to take access on https://svn.mydomain.com/code works fine!
>
> Is this a known issue?
>

I have no experience in this area at all, but have you tried clearing
the TSVN authorisation cache (Settings, Saved Data, Clear
authentication data)?

-- 
Regards,
Jean-Marc
--
.       ___
.  @@  // \\      "De Chelonian Mobile"
. (_,\/ \_/ \     TortoiseSVN
.   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
.   /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2616774
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-06-04 10:30:06 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.