[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: client-side hooks , always this error:The hook script returned an error

From: Simon Large <simon.tortoisesvn_at_googlemail.com>
Date: Sun, 9 May 2010 22:07:46 +0100

On 6 May 2010 14:57, hjz <hujianzhong_at_huawei.com> wrote:
> hello,
> I'm new in using TSVN, and have difficulties with setting up client-side hooks. I'm using TortoiseSVN 1.5.9-32 Bit on Win XP. Working copy is in D:\WC and hook script settings are:
>
> Hook Type: Start Commit Hook
> Working Copy Path: D:\WC
> Commmand Line To Execute: D:\WC\batfile.bat
> Wait for the script to finish: checked
> Hide the script while running: unchecked
>
> I also tried command lines:
> cmd D:\WC\batfile.bat
> cmd.exe /c D:\WC\batfile.bat
>
> The batfile.bat file contains only one line:
>
> exit 0
>
> I always get "The hook script returned an error:" message when trying to commit. Without the script, commit works just fine.
>
> What am I doing wrong?

You get the same error message if the hook script does not exist, for
example if you enter the wrong hook script path in the settings
dialog.

Simon

-- 
:       ___
:  oo  // \\      "De Chelonian Mobile"
: (_,\/ \_/ \     TortoiseSVN
:   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
:   /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2606281
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-05-09 23:07:52 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.