[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

client-side hooks , always this error:The hook script returned an error

From: hjz <hujianzhong_at_huawei.com>
Date: Thu, 6 May 2010 06:57:46 -0700 (PDT)

hello,
I'm new in using TSVN, and have difficulties with setting up client-side hooks. I'm using TortoiseSVN 1.5.9-32 Bit on Win XP. Working copy is in D:\WC and hook script settings are:

Hook Type: Start Commit Hook
Working Copy Path: D:\WC
Commmand Line To Execute: D:\WC\batfile.bat
Wait for the script to finish: checked
Hide the script while running: unchecked

I also tried command lines:
cmd D:\WC\batfile.bat
cmd.exe /c D:\WC\batfile.bat

The batfile.bat file contains only one line:

exit 0

I always get "The hook script returned an error:" message when trying to commit. Without the script, commit works just fine.

What am I doing wrong?

the same as below :
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&viewType=browseAll&dsMessageId=1318067#messagefocus

PS:
1、i had try this hook script on three computers,and only one works ok and the other two return error.
2、three computer all have Symantec/Norton security software installed, it was controlled by company, and the configure of hte secutity should the same.

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2604249

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-05-06 16:39:49 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.