[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Log messages don't always update

From: Dennis Jones <djones_at_grassvalleysoftware.com>
Date: Thu, 15 Oct 2009 15:34:15 -0700

"Stefan Küng" <tortoisesvn_at_gmail.com> wrote in
message news:4AD76875.8030806_at_gmail.com...
> On 15.10.2009 17:13, Dennis Jones wrote:
>>
>> I checked the current ChangeLog and found an entry for version 1.6.6 that
>> sounds like it could be related to the problem, but I am not sure:
>>
>> - BUG: Under rare conditions, missing data would not be added
>> to the log cache. (Stefan Fuhrmann)
>>
>> Can anyone confirm that my issue is the same as the one mentioned in the
>> changelog?
>>
>> Can anyone else replicate this behavior?
>
> Everyone can reproduce this, because it is by design.
> The log cache is the reason: it caches already fetched log entries on
> the disk so they won't have to be fetched from the repository anymore.
> But because those entries are not fetched from the repository anymore,
> any changes to such entries are not shown, because they're not in the
> cache. Those entries were changed in the repository after they've been
> cached.
> To refresh the cache, you have to either delete the whole cache
> (settings dialog) or hit Ctrl-F5 in the log dialog. Only then will the
> log dialog fetch the entries again from the repository.

Thank you, Stefan. I was not aware that I could use Ctrl+F5 to refetch the
information from the repository.

- Dennis

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2408051

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-10-16 08:01:45 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.