[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Update raises "Subversion Exception!" in libsvn_ra_svn\marshal.c:486

From: Andy Levy <andy.levy_at_gmail.com>
Date: Thu, 28 May 2009 08:28:39 -0400

On Thu, May 28, 2009 at 06:52, Paul Lammertsma <pflammertsma_at_gmail.com> wrote:
> Hi TortoiseSVN developers,
>
> I'm a long-time user of Tortoise and love it! I recently upgraded to 1.6.2,
> and have run into the following exception when performing an update:
>
> Subversion Exception!
>
> Subversion encountered a serious problem.
> Please take the time to report this on our mailing list
> with as much information as possible about what
> you were trying to do.
>
> Subversion reported the following:
>
> In file
> 'D:\Development\SVN\Releases\TortoiseSVN-1.6.2\ext\subversion\subv
> ersion\libsvn_ra_svn\marshal.c'
> line 486: assertion failed (opt || cstr)
>
> The only thing I was doing "out of the ordinary" was updating my working
> copy from 1.6.0 to 1.6.2 with an SVN update. I just ran the update again,
> and the exception wasn't raised a second time.

This is a defect in the core Subversion libraries, not TSVN. It's been
reported many times.

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2356122

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-05-28 14:28:51 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.