[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Explorer still slow - version 1.5.9

From: Glen Little <glen.little_at_gmail.com>
Date: Tue, 31 Mar 2009 15:06:59 -0700 (PDT)

I have kept all the check boxes off, not selecting any drive type.

I presume that the problem occurs because the program has to scan each
drive to determine what type it is, to decide whether to watch it or
not.

Glen

On Mar 31, 8:11 am, Bob Archer <bob.arc..._at_amsi.com> wrote:
> Can't you just tell it to not include any drive types, and just put in the include folder that paths you want it to watch?
>
> BOb
>
>
>
> > -----Original Message-----
> > From: Glen Little [mailto:glen.lit..._at_gmail.com]
> > Sent: Monday, March 30, 2009 6:08 PM
> > To: us..._at_tortoisesvn.tigris.org
> > Subject: Re: Explorer still slow - version 1.5.9
>
> > I put all my drives into the "exclude" box:
> > D:\*
> > e:\*
> > F:\*
> > G:\*
> > ...etc.
>
> > However, that does not seem to fix the problem... and I don't see how
> > it would.
>
> > I still think we need the option of supplying a list of drive names,
> > and not rely on the "drive type" concept.
>
> > GLen
>
> > On Mar 26, 9:04 am, "Todd C. Gleason" <tglea..._at_impac.com> wrote:
> > > > -----Original Message-----
> > > > From: Kurt Pruenner [mailto:l..._at_gmx.at]
> > > > Sent: Thursday, March 26, 2009 2:36 AM
> > > > To: us..._at_tortoisesvn.tigris.org
> > > > Subject: Re: Explorer still slow - version 1.5.9
>
> > > >Glen Littlewrote:
> > > > > From older discussions and support comments, I understand that
> > > Tortoise
> > > > > is surveying each drive to determine its type - whether it is a
> > > network
> > > > > drive, RAM drive, etc.
>
> > > > > Could this approach please be changed?
>
> > > > Have you tried unchecking all drive types, setting the excluded paths
> > > to
> > > > "*" and including the paths where your working copies are (like
> > > > "C:\Code*" for everything under "C:\Code") under include paths?
>
> > > > Also, what about TSVN 1.6.0?
>
> > > In addition to trying TSVN 1.6.0, did you try explicitly adding the
> > > drive to your Exclude paths?  If that doesn't work, then I would say it
> > > might be a fixable bug.  Perhttp://www.nabble.com/Windows-Explorer-very-
> > very-slow-td18715677.html,
> > > TSVN checks the drive type of each drive when it starts up, but given
> > > that this API is slow to respond, one would think it would/could first
> > > see if the entire drive path is Excluded in the first place.
>
> > > ------------------------------------------------------
> >http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMess...
>
> > > To unsubscribe from this discussion, e-mail: [users-
> > unsubscr..._at_tortoisesvn.tigris.org].
>
> > ------------------------------------------------------
> >http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMess...
> > =1486909
>
> > To unsubscribe from this discussion, e-mail: [users-
> > unsubscr..._at_tortoisesvn.tigris.org].
>
> ------------------------------------------------------http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMess...
>
> To unsubscribe from this discussion, e-mail: [users-unsubscr..._at_tortoisesvn.tigris.org].

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=1500156

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-04-01 01:43:58 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.