[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: TortoiseSVN requiring multiple authentications against svnserve repository

From: Simon Large <simon.tortoisesvn_at_googlemail.com>
Date: Thu, 18 Sep 2008 10:44:59 +0100

2008/9/18 neromir <neromir_at_gmail.com>:
> Hi guys,
>
> I've got an svn repository (1.3.x) set up on a linux box here at home,
> serving it with svnserve, and I'm trying to do some directory/project-
> specific authentication with it through the authz functionality.
>
> The problem is that when I try to view the repository with TortoiseSVN
> (repo-browser) it's requiring me to authenticate my username 3 times
> just to get to the base of the repository. I know I could probably
> save my authentication in the box and that might fix it, but I'd
> rather not have to do that every time in the event I'm using a public
> computer. So is this a bug with Tortoise, or is this something wrong
> with my authz configuration?

No, not a bug. Each server round trip requires authorization and some
commands take several round trips. If you don't save the auth then it
does get tedious.

Simon

-- 
: ___
: oo // \\ "De Chelonian Mobile"
: (_,\/ \_/ \ TortoiseSVN
: \ \_/_\_/> The coolest Interface to (Sub)Version Control
: /_/ \_\ http://tortoisesvn.net
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-09-18 11:45:13 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.