[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Possible bug: TortoiseProc.exe /command:update "skips" updating files after installing Tortoise 1.5

From: Marcus Boström <marcus.bostrom_at_studentum.se>
Date: Fri, 4 Jul 2008 11:14:18 +0200

Hi Stefan & Ron,

Permissions are set to "Everyone - Full control" for all folders, subfolders and files that are version controlled. The context-command works fine and we have reproduced the same behavior on the second machine which we also updated to 1.5. I definitely think we are on the right track with investigating permission issues since we needed to add the /notempfile to get the script to work with the previous version. Is there some way to getting a more detailed error message?

Best regards
Marcus Boström
CTO & Founder
----------------------------
Studentum AB
Torstenssonsgatan 4, 4tr
114 56 Stockholm
Tel: +46 (0)8 509 106 00
Direct: +46 (0)8 509 106 30
Mobile: +46 (0)70-471 37 22
Fax: +46 (0)8 509 106 99
marcus.bostrom_at_studentum.se

www.studentum.se
www.utbildning.se
www.kurser.se
www.gymnasium.se
www.kyutbildningar.se
www.yrkesutbildningar.se
www.sprakreseguiden.se
www.plugga-utomlands.se
www.distansutbildningar.se
www.mimersbrunn.se
www.studentum.no
Hitta din utbildning!

-----Original Message-----
From: Stefan Küng [mailto:tortoisesvn_at_gmail.com]
Sent: den 3 juli 2008 19:04
To: users_at_tortoisesvn.tigris.org
Subject: Re: Possible bug: TortoiseProc.exe /command:update "skips" updating files after installing Tortoise 1.5

Marcus Boström wrote:

> First of all, thanks for a great product! I will make sure that my
> company donates some money to support future development of this
> killer-appJ
>
>
> I think I may have found a little bug though. After upgrading to
> version
> 1.5 our automatic build-script which also updates the source files
> from our repository stopped working. We use the command line
> executable TortoiseProc with the following command
>
> C:\Progra~1\TortoiseSVN\bin\TortoiseProc.exe /command:update
> /path:ClassLibrary /notempfile /closeonend:3
>
>
> In the earlier version, this command would update all files in the
> ClassLibrary folder but now the update dialog opens up but for some
> reason continues without updating any files. The output reads
>
> -command update
> -skipped ClassLibrary
> -Finished!

>
> And we can’t really figure out why it in version 1.5 choose to skips
> updating the files. The path ClassLibarary is a subfolder to the
> repository root if that would make any difference. I have tried to
> remove /notempfile since it’s now obsolete but that does not make any
> difference. Am I missing something?

The command you mentioned works fine for me here.
Are you sure that you have write access to the working copy? What happens if you use the context-menu "update" command?

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-07-04 11:18:11 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.