[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Explorer plugin tries to open D:\.svn\entries even if D:\.svn does not exists

From: Stefan Kng <tortoisesvn_at_gmail.com>
Date: 2007-09-20 09:15:14 CEST

On 9/19/07, Carsten Schuette <carsten.schuette@gmx.de> wrote:

> I did some traces with Sysinternal's Filemon and Procmon and found out that
> the explorer plugin (tried with nightly build 10550) even tries to open
> "D:\.svn\entries" when "D:\.svn" does not exists. I was sure that this was
> fixed and I am not able to reproduce it, buit sometimes it happens. Maybe
> somebody can have a look at it again?

If it happens only some times, why does it bother you that much?

> I also saw that the explorer plugin first looks for "D:\.svn" and that for
> "D:\_svn", even if I have set my options that I only want to use "_svn"
> directory names. TSVNCache.exe does the same.

Yes, of course.
You can't specify that you *only* want to use _svn admin dir names,
but only that you *prefer* to use them. The original ".svn" are
recognized and used even with that setting enabled. All it does is to
tell Subversion that it should recognize _svn folders too.

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: users-help@tortoisesvn.tigris.org
Received on Thu Sep 20 09:15:21 2007

This is an archived mail posted to the TortoiseSVN Users mailing list.