[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Show log: 'C:\Documents and Settings\...' is not a working copy

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: 2006-04-24 10:59:07 CEST

On 4/24/06, Michael Madsen <michael@birdiesoft.dk> wrote:

[snip]
> This junction point should behave exactly like the actual folder, and for the
> most part, it does - updating and commiting is no problem.
>
> However, if I try to show the log from the junction point, I get the message
> that "'C:\Documents and Settings\...' is not a working copy". Why does TSVN
> generate this error, when it doesn't mind updating and commiting? Why does it
> matter at all whether or not it's a working copy, if all I want to do is see
> the log? And finally, is there anything I can do to allow BOTH locations to be
> recognized as working copies without actually checking the repository out in
> two different locations?

junction points are not fully supported by Subversion right now. It's
both a problem of apr and Subversion. I think Subversion 1.4 will
recognize junction points completely (if linked to a recent apr
version).

Stefan

--
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.tigris.org
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: users-help@tortoisesvn.tigris.org
Received on Mon Apr 24 10:59:21 2006

This is an archived mail posted to the TortoiseSVN Users mailing list.