[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Line info tooltips in TBlame

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Tue, 17 May 2011 19:02:57 +0200

On 17.05.2011 00:12, Simon Large wrote:
> When moving the mouse pointer over the info area in TBlame the tooltip
> flickers as the mouse moves. This may be simply because the tooltip
> has to keep redrawing to follow the mouse, in which case there is not
> much that can be done. I tried to remember the reason that it does
> follow the mouse and I think it is because the tooltip can obscure
> other parts of the display, notably the code you are blaming, so
> having it attached to the mouse means you can move the tooltip out of
> the way.
>
> Having said that you can drag a normal dialog around, including the
> TBlame main window, and the flickering is far less than it is with the
> tooltips. It looks as if the tooltip area is being cleared completely,
> repainted and then filled in again and repainted.

Fixed in r21392.

> I also note that the tooltips come up even when the blame window does
> not have focus.

That's the default behavior. Try it with Firefox :)

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=757&dsMessageId=2739374
To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-05-17 19:03:09 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.