[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Missing pegged externals in repo-browser

From: Oddvar Kloster <Oddvar.Kloster_at_sintef.no>
Date: Wed, 6 Oct 2010 16:14:21 +0200

> -----Original Message-----
> From: Stefan.Fuhrmann_at_etas.com [mailto:Stefan.Fuhrmann_at_etas.com]
> Sent: 4. oktober 2010 12:16
> To: dev_at_tortoisesvn.tigris.org
> Subject: RE: Missing pegged externals in repo-browser
>
> > On 28.09.2010 Oddvar Kloster wrote:
> > > From: Stefan K√ľng [mailto:tortoisesvn_at_gmail.com]
> > >
> > > On 27.09.2010 11:35, Oddvar Kloster wrote:
> > > > The repo-browser does not display externals in the list view if
> > > > they are pegged to a revision. Using trunk, r20190.
> > >
> > > Showing TSVN ext directory shows me all externals, even those with
> pegged
> > > revisions.
> > > What format do your externals have?
> > >
> > > Stefan
> >
> > I refer to externals with pegs using the path_at_rev syntax. I find no
> examples of these in the TSVN ext dir.
>
> I added peg revision support in r20218
> but have not tested it extensively, yet.
> Take the latest nightly and give it a try ;)
>
> -- Stefan^2.

Seems good, except that I still don't see pegged externals ;-)
Possibly the only thing that's missing is removing the test in RepositoryLister.cpp, line 293. If I do this, the pegged externals appear as expected.

Oddvar

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=757&dsMessageId=2668590

To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-10-06 16:17:28 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.