[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Patch: reducing amount of duplicate code

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Thu, 10 Sep 2009 20:07:54 +0200

On 10.09.2009 08:21, Dmitry wrote:
> In this patch I've rewritten a couple of methods to have less nesting
> and repeating code, replaced "NOERROR" with "S_OK" for HRESULT return
> values. I also introduces a local variable "menuLock" to remove
> repeating evaluation of the same expression but I guess it deserves a
> more meaningful name that I couldn't invent.

Sorry, but I can't apply this patch. It doesn't compile and when I fix
the compiler errors, the context menu isn't 'context' anymore but shows
all entries all the time.

But I've replaced the NOERROR with S_OK in r17152.


   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-09-10 20:08:02 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.