[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Patch: reducing amount of duplicate code

From: Dmitry <wipedout_at_yandex.ru>
Date: Thu, 10 Sep 2009 10:21:56 +0400

In this patch I've rewritten a couple of methods to have less nesting and repeating code, replaced "NOERROR" with "S_OK" for HRESULT return values. I also introduces a local variable "menuLock" to remove repeating evaluation of the same expression but I guess it deserves a more meaningful name that I couldn't invent.



To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].

Received on 2009-09-10 08:43:37 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.