[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [TSVN] Icon overlays still not correct

From: Simon Large <simon_at_skirridsystems.co.uk>
Date: 2005-07-14 11:17:05 CEST

SteveKing wrote:
> Simon Large wrote:
>
>> I don't know if this helps at all, but I found a non-updating overlay
>> status in my TSVN trunk WC. Steps to reproduce:
>>
>> Open a single fresh explorer window and navigate so that left pane
>> shows the top level trunk structure:
>>
>> TortoiseSVN (this is my trunk folder)
>> +bin
>> +contrib
>> +doc
>> +ext
>> etc
>>
>> Right pane shows contents of doc folder.
>>
>> Double click on CreatePot.bat
>>
>> When the pot creation is finished, the po folder in the right pane
>> doesn't get modified. Waiting a while and pressing F5 does not help.
>
>
> Wrong sequence. Press F5 first and *then* wait a while. It can take
> really a while until the crawler reaches that folder and the recursive
> status gets updated.

Press F5. Wait 2 minutes. Press F5. No disk activity and no overlay
update. Wait another 15 minutes. Press F5. Now we get disk churn and the
overlay updates after about 5 seconds. In the registry I have
CacheTimeout set to 600000. I don't remember setting this explicitly and
I thought it had been increased to MAX_INT before the 1.2.0 release.

I forgot to mention the build. r3769. It's not the latest, but there
have been no changes which seem relevant to this in TSVNCache or
TOrtoiseShell since then.

Simon

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.tigris.org
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Thu Jul 14 11:16:25 2005

This is an archived mail posted to the TortoiseSVN Dev mailing list.