[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Re: [Subclipse-users] Performance problem with recursive status

From: Mark Phippard <mphippard_at_collab.net>
Date: Thu, 18 Dec 2008 16:05:17 -0500

On Thu, Dec 18, 2008 at 4:03 PM, <postmaster_at_tigris.org> wrote:
> In Eclipse, the Help->Software Updates menu pulls up a dialog where the first tab lists Installed Software.
>
> If I highlight Subclipse in this list, then click the "Uninstall..." button to the right, it appears to remove subclipse, as it no longer shows up in the list. However, the plugin directories are still under c:\eclipse\plugins, and subclipse event handlers are still fired and still try to update the status which still takes 45 minutes. However, there is no visual indication that subclipse is still installed, as all the GUI elements of subclipse are no longer in eclipse. (e.g. You can't see the status for each file, and the Team context menu has no subversion items.
>
> I suspect that there is some callback that uninstalled plugins are required to handle so that they can unregister from build events.

If you learn of such a requirement feel free to forward it. To me it
looks like the plugin uninstall in Eclipse is simply broken.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=986974
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2008-12-18 22:05:29 CET

This is an archived mail posted to the Subclipse Users mailing list.