[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Automatic project share

From: Marco Maccaferri <macca_at_maccasoft.com>
Date: Mon, 25 Aug 2008 17:08:08 +0200 (CEST)

Mark Phippard wrote:

> I do not believe anything has changed in this area. I have attached a
> diff from the 1.4.0 and 1.4.3 tags as reference.

My knowledge of the Eclipse API is not so deep to understand how a team
provider plugin hooks to the resources management, so I can't understand
what changes are affecting this feature, but certainly something has
changed between subclipse 1.4.2 and 1.4.3 because this feature doesn't
work anymore.

You can test it fairly easy, checkout a workspace from svn (even an empty
workspace). Create a new project and check if Eclipse asks to add the
project to the repository. If the dialog pops out then something is wrong
with my setup, if doesn't appear then something changed in subclipse.

I have tested it right now, under Windows, with subclipse 1.4.2 it worked
(it asked me to add the new project to the repository), with subclipse
1.4.3 it doesn't work anymore, same workspace, same settings. I can't see
the dialog, and also believe that something else is broken because if I
manually add the project to the repository (from the command line, not
from Eclipse), subclipse doesn't detect that it is already shared and
doesn't show the decorators even after refreshing the workspace.

Regards,
Marco.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_subclipse.tigris.org
For additional commands, e-mail: users-help_at_subclipse.tigris.org
Received on 2008-08-25 17:12:25 CEST

This is an archived mail posted to the Subclipse Users mailing list.