[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Subclipse 1.4 not working on Ubuntu 8.04.1 amd64

From: Dean Schulze <dean_w_schulze_at_yahoo.com>
Date: Fri, 15 Aug 2008 09:10:07 -0700 (PDT)

I uninstalled all Subclipse packages from Eclipse and re-installed it using SVNKit (omitting JavaHL) and everything seems to work.

After reading the rest of this thread it's not clear to me why this is a problem on 64 bit systems but not on 32 bit systems.

Another one of the joys of using Eclipse on 64 bit Ubuntu systems is that it crashes frequently if you start it with the Eclipse icon. The solution (which is documented on several blogs) is to start it from the command line.

The problems with the Eclipse launcher might be related to the potential problems that others have made about modifying eclipse.ini, but I doubt it.

--- On Fri, 8/15/08, Markus Schnhaber <subclipse-users_at_list-post.ddt-consult.de> wrote:
From: Markus Schnhaber <subclipse-users_at_list-post.ddt-consult.de>
Subject: Re: [Subclipse-users] Subclipse 1.4 not working on Ubuntu 8.04.1 amd64
To: users_at_subclipse.tigris.org
Date: Friday, August 15, 2008, 2:59 AM

Dean Schulze wrote:

> I found the 64 bit .rpm for CollabNetSubversionClient and installed
> it. I've put the 64 bit version 1.5.1 client in my PATH in front of
> the 1.4.6 version. When I try to add a repository I get this
> message:
>
> Error validation location: "Unable to load default SVN Client"
>
> What's the missing step? Do I have to put the CollabNet client lib/
> directory in LD_LIBRARY_PATH? Do I have to uninstall the older
> client in /usr/bin/svn? Something else?

You have to make sure that
a) the javahl lib came with te RPM you installed, and
b) LD_LIBRARY_PATH points to the location where libjavahl resides.

Regards
  mks

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_subclipse.tigris.org
For additional commands, e-mail: users-help_at_subclipse.tigris.org
Received on 2008-08-15 18:10:22 CEST

This is an archived mail posted to the Subclipse Users mailing list.