[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Blame (annotate) issues in subclipse 1.4.3

From: Mark Phippard <markphip_at_gmail.com>
Date: Thu, 14 Aug 2008 15:31:05 -0400

On Thu, Aug 14, 2008 at 3:26 PM, Gene Gorokhovsky
<ggorokhovsky_at_apriori.com> wrote:
>
> We actually do detect the error you get when using -g with a pre-1.5
> server, and we then just re-issue the API without that option.
>
>
> After talking to our sysadmin, I am told the server version is now 1.5.0
> (r31699), but the repository itself has not been converted.
>
> I have raised the issue on the core SVN user mailing list, but I am not
> sure whether a separate issue also needs to be filed for subclipse.

File an issue to let us expose UI to not always provide the -g option.
 Since our existing blame feature did not have UI, I initially just
hard-coded and handled the error when talking to a 1.4 server.

I've been wanting to add a UI that let you specify the revision range,
so I think that is the best answer. It takes 1-2 seconds for the -g
option to fail with a 1.4 server so there would be value in fixing
that.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_subclipse.tigris.org
For additional commands, e-mail: users-help_at_subclipse.tigris.org
Received on 2008-08-14 21:31:15 CEST

This is an archived mail posted to the Subclipse Users mailing list.