[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Externals property bug - folder UI

From: Mark Phippard <markphip_at_gmail.com>
Date: Wed, 25 Jun 2008 08:06:37 -0700

On Wed, Jun 25, 2008 at 8:04 AM, Hale,Katherine <halek_at_oclc.org> wrote:

> Thanks for the response. I still feel like it's a kind of bug, in either
> the Subversion API itself or how the Subclipse plug-in reacts to the
> .svn folders (or lack thereof in this scenario). I was just referencing
> Tortoise if it helped reproduce the behavior.
>
> I'm just frustrated with this behavior because there doesn't seem to by
> any way around it, short of simply avoiding the scenario. If you live
> with the false positives, you have to be careful to avoid them at every
> commit. If you synchronize, override & update the "changes", Eclipse
> will actually delete the local copy of your externals - completely
> defeating the purpose. I understand why this happens, I'm just saying
> it's no longer intuitive.

Can you file an issue? Perhaps the side effects can still be handled.
 Not sure though.

What I usually do is add the intermediate folders to my main project
and then just add the svn:external property to the last folder so that
there are no unversioned folders.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_subclipse.tigris.org
For additional commands, e-mail: users-help_at_subclipse.tigris.org
Received on 2008-06-25 17:06:53 CEST

This is an archived mail posted to the Subclipse Users mailing list.