[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Compare With Latest in Repository does not work at the folder lev el anymore!

From: Mark Phippard <markp_at_softlanding.com>
Date: 2006-03-13 19:35:16 CET

Simon Baynes <Simon.Baynes@haynet.com> wrote on 03/13/2006 07:13:52 AM:

> Since installing Subeclipse 0.9.108 I cannot use Compare with latest
from
> repository at the folder level anymore. It displays an alert box with no

> message instead. I can do it on a file by file basis no problem, but it
just
> won’t work with a folder or project.
>
> If you need anymore information let me know.

This is still working OK for me, but there have been problems in this area
before. The problem is that a NPE happens deep in the compare code. For
some reason the compare engine does not surface the error very well. These
problems have been hard to solve in the past, even when they were easily
reproducable. Unless you can find a reliable way to trigger it, the best
I can say is that it probably will not effect all of your projects and
might even just go away on its own.

Sorry.

Mark

_____________________________________________________________________________
Scanned for SoftLanding Systems, Inc. and SoftLanding Europe Plc by IBM Email Security Management Services powered by MessageLabs.
_____________________________________________________________________________
Received on Mon Mar 13 19:35:40 2006

This is an archived mail posted to the Subclipse Users mailing list.