[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Unable to install

From: Paul Lalonde <paullalonde_at_mac.com>
Date: 2005-04-24 20:09:50 CEST

> "Joe ." <japher@hotmail.com> wrote on 03/21/2005 11:13:09 AM:
>
>> I'm attempting to install Subclipse 0.9.28 on Eclipse Version: 3.0.1,
>> Build id: 200409161125 but always receive the following error: -
>>
>> Subclipse (0.9.28) requires plug-in "org.eclipse.core.resources".

...

> It sounds like you have some corruption in your Eclipse configuration.
> Try
> closing Eclipse and then restarting it with -clean added to the command
> line options. This will hopefully fix the plugin configuration.

I've been having the same problem. Restarting eclipse with -clean had
no effect. I was running a clean install of Eclipse 3.0.2 (ie 3.0.2 was
installed directly, it was not an upgrade). I finally solved the
problem by removing Eclipse 3.0.2 and re-installing Eclipse 3.0. The
installation process for Subclipse then worked fine. I then upgraded
to Eclipse 3.0.2, and Subclipse continued to work.

So, Subclipse appears to have a dependency on the specific version of
the org.eclipse.core.resources plugin that ships with Eclipse 3.0.

This is on Mac OS X 10.3.9, using Subclipse 0.9.30.

-- 
Paul Lalonde, néoesclave            paullalonde at mac dot com
Received on Mon Apr 25 04:09:50 2005

This is an archived mail posted to the Subclipse Users mailing list.