[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [ANN] JavaSVN v0.8.8 - broke my working copies?

From: Hugo Visser <joegi_at_scene.nl>
Date: 2005-04-20 22:17:12 CEST

Thanks Alexander,

Didn't know about that view, but you're right:

? 2005 22:02:27.46 While loading class
"org.tigris.subversion.subclipse.ui.console.ConsoleDocument$ConsoleLine",
thread "main" timed out waiting (5000ms) for thread "Worker-0" to finish
starting bundle "org.tigris.subversion.subclipse.ui". To avoid deadlock,
thread "main" is proceeding but
"org.tigris.subversion.subclipse.ui.console.ConsoleDocument$ConsoleLine"
may not be fully initialized.

java.lang.Exception: Generated exception.
at
org.eclipse.core.runtime.adaptor.EclipseClassLoader.findLocalClass(EclipseClassLoader.java:102)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:371)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:402)
at
org.eclipse.osgi.framework.adaptor.core.AbstractClassLoader.loadClass(AbstractClassLoader.java:93)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at
org.tigris.subversion.subclipse.ui.console.ConsoleDocument.getLines(ConsoleDocument.java:79)
at
org.tigris.subversion.subclipse.ui.console.SVNOutputConsole.dump(SVNOutputConsole.java:202)
at
org.tigris.subversion.subclipse.ui.console.SVNOutputConsole.access$1(SVNOutputConsole.java:199)
at
org.tigris.subversion.subclipse.ui.console.SVNOutputConsole$1.run(SVNOutputConsole.java:124)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at
org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:106)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:2750)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2435)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1377)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1348)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:254)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:141)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:96)
at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:335)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:273)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:129)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.basicRun(Main.java:185)
at org.eclipse.core.launcher.Main.run(Main.java:704)
at org.eclipse.core.launcher.Main.main(Main.java:688)

Then followed by

Project {0} does not contain SVN folder meta-information.

in a separate error.

If I turn off the svn console, all I get is the last error. THe project
does have .svn dirs, but subclipse does not recognize them for some
reason...

Hugo

Alexander Kitaev wrote:
> I may suggest you to look into Eclise error log. There is standard Eclipse
> view called "Error Log" that could help to find the reason of the problem. I
> think that in your case Subclipse plugin was not loaded properly.
>
>
>>-----Original Message-----
>>From: Hugo Visser [mailto:joegi@scene.nl]
>>Sent: Wednesday, April 20, 2005 9:50 PM
>>To: users@subclipse.tigris.org
>>Subject: Re: [ANN] JavaSVN v0.8.8 - broke my working copies?
>>
>>
>>I'm on 3.0.2, and I'm not using JavaSVN but javahl. I've
>>never installed
>>JavaSVN :) I've uninstalled subclipse I'm now trying to go back a few
>>versions but my guess is that something I've updated to Eclipse broke
>>subclipse, but I'm not sure. When I startup eclipse hangs for
>>a moment,
>>the svn console gets focus and then the project is decorated
>>empty, like
>>"project []".
>>
>>Hugo
>>
>>Alexander Kitaev wrote:
>>
>>>What version of Eclipse do you use. I think that javasvn 0.8.8 lost
>>>compatiblity with Eclipse < 3.1 (I'm testing it with Eclipse 3.1M6).
>>>
>>>Alexander Kitaev.
>>>
>>>
>>>
>>>>-----Original Message-----
>>>>From: Hugo Visser [mailto:joegi@scene.nl]
>>>>Sent: Wednesday, April 20, 2005 9:19 PM
>>>>To: users@subclipse.tigris.org
>>>>Subject: Re: [ANN] JavaSVN v0.8.8 - broke my working copies?
>>>>
>>>>
>>>>Just wanted to add that the working copy seems okay. svn -v status
>>>>reports status as it should...same subversion on my laptop is
>>>>okay, I am
>>>>using another eclipse version on my laptop though...
>>>>
>>>>Hugo Visser wrote:
>>>>
>>>>
>>>>>Hi,
>>>>>
>>>>>I've noticed the same thing today, my project isn't
>>>>
>>>>decorated anymore,
>>>>
>>>>
>>>>>and some options like synchronize are grayed out. I'm using javahl
>>>>>however. I think this happened when I upgraded to
>>>>
>>>>subversion 0.9.30,
>>>>
>>>>
>>>>>which I'm also using on my laptop (which is my work laptop
>>>>
>>>>that I use
>>>>
>>>>
>>>>>svn with every day). I've tried eclipse -clean, a new
>>>>
>>>>workspace and even
>>>>
>>>>
>>>>>a complete new eclipse install, but no to avail.
>>>>>
>>>>>I see no errors in the svn console what so ever. Any hints?
>>>>>
>>>>>Hugo
>>>>>
>>>>>Toby Thain wrote:
>>>>>
>>>>>
>>>>>
>>>>>>On 19-Apr-05, at 1:12 PM, Alexander Kitaev wrote:
>>>>>>
>>>>>>
>>>>>>
>>>>>>>Hello All,
>>>>>>>
>>>>>>>JavaSVN v0.8.8 is available for download at the web site
>>>>>>>http://tmate.org/svn/ and via eclipse update manager (use
>>>>>>>http://tmate.org/svn/ as update site location).
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>Alexander
>>>>>>
>>>>>>After I upgraded, my working copies (C/C++) ceased to be
>>>>
>>>>recognised
>>>>
>>>>
>>>>>>as
>>>>>>such (no badges, no rev/date/committer titles in browser view).
>>>>>>Subclipse 0.9.30.
>>>>>>
>>>>>>Toby
>>>>>>
>>>>>>
>>>>>>
>>>>
>>>>------------------------------------------------------------
>>
>>---------
>>
>>>>>>To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
>>>>>>For additional commands, e-mail: users-help@subclipse.tigris.org
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>------------------------------------------------------------
>>
>>---------
>>
>>>>>To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
>>>>>For additional commands, e-mail: users-help@subclipse.tigris.org
>>>>>
>>>>>
>>>>
>>>>------------------------------------------------------------
>>
>>---------
>>
>>>>To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
>>>>For additional commands, e-mail: users-help@subclipse.tigris.org
>>>>
>>>>
>>>
>>>
>>>
>>>
>>---------------------------------------------------------------------
>>
>>>To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
>>>For additional commands, e-mail: users-help@subclipse.tigris.org
>>>
>>>
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
>>For additional commands, e-mail: users-help@subclipse.tigris.org
>>
>>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
> For additional commands, e-mail: users-help@subclipse.tigris.org
>
>
Received on Thu Apr 21 06:17:12 2005

This is an archived mail posted to the Subclipse Users mailing list.