[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Re: Using Subclipse with svn+ssh:// on Windows (with plink)

From: Haiges, Sven, Vodafone Group R&D <Sven.Haiges_at_vodafone.com>
Date: 2005-04-15 10:08:35 CEST

Hi Dan, all.
 
it's getting interesting now... where do you put the second line, that
tells eclipse where your ssh command is?
 
Thanx,
Sven
 
 
 

-----Original Message-----
From: Dan North [mailto:dan@tastapod.com]
Sent: Friday, April 15, 2005 9:52 AM
To: users@subclipse.tigris.org
Subject: Re: Using Subclipse with svn+ssh:// on Windows (with plink)

I'm using linux now, but I seem to remember having to work around this
in windows. I wrote a one-line cmd file called plink2.cmd and put it on
my path:

plink -2 %*

Then I told eclipse that my ssh command was plink2.cmd. You can use this
for debugging too, by adding a line like this:

@echo %* >> \temp\plink2.log

to see how plink2 is being invoked. I'm sure others on the list will
have more current methods :)

hth,
Dan

Haiges, Sven, Vodafone Group R&D wrote:

Hi Dan, all,

thanx for your help so far. I added the -2, so it now is

plink -2 -l username etc.

Unfortunately, it still does not workd. I can see a putty / windows cmd

window popping up (as it was before, with username/password), but then

nothink happens.

It is interesting: If I try plink on the cmd line, (I have to add the

server address after the command then, but that's clear), it works. So

somehow I think subclipse adds the information about the svn repository

path maybe at the wrong place or...?

Do you use sublcipse with plink and the svn+ssh:// protocoll? Are there

any other options for plinks?

thanx!

Sven

-----Original Message-----

From: Dan North [ mailto:dan@tastapod.com]

Sent: Friday, April 15, 2005 9:09 AM

To: users@subclipse.tigris.org

Subject: Re: Using Subclipse with svn+ssh:// on Windows (with plink)

Hi Sven.

Two things:

Firstly, plink uses ssh protocol 1 (the deprecated, buggy one) by

default, so your command should be "plink -2 ..." to force protocol 2

(and enable your ssh2 key). Secondly, you should take a look at pageant,

which is the putty ssh key agent. You run it at startup, type in your

passphrase and then whenever a plink or putty session requires the key,

it talks directly to pageant. (It also gives you a taskbar icon for

launching putty sessions.) This is a huge time saver - it means you can

protect your private key file and not have to type in your password all

the time.

Cheers,

Dan

Haiges, Sven, Vodafone Group R&D wrote:

  

Hi there,

we got subversion running on a server and are only allowed to connect

via svn+ssh://. It is all set up correctly, TortoiseSVN works great but

I would like to use subclipse directrly from Eclipse.

I set the SVN_SSH environment variable to

plink -l username -i "path to my putty private key file" -A

but it does not work. I previously used password authentication, e.g.

    

-l

  

username -p password and it worked great.

Do you have any ideas how we can get it working with public/private key

authentication? Does anyonle of you connect to a subersion server via

svn+ssh:// on a Windows client with Ecliipse and Subclipse?

Any help is appreciated,

thanx, Sven

---------------------------------------------------------------------

To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org

For additional commands, e-mail: users-help@subclipse.tigris.org

 

    

---------------------------------------------------------------------

To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org

For additional commands, e-mail: users-help@subclipse.tigris.org

---------------------------------------------------------------------

To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org

For additional commands, e-mail: users-help@subclipse.tigris.org

  
Received on Fri Apr 15 18:08:35 2005

This is an archived mail posted to the Subclipse Users mailing list.