[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

AW: Subclipse ecplise 2.1 and svn 1.0

From: Alblas Huibert <Huibert.Alblas_at_metro-cc.de>
Date: 2004-05-04 10:17:06 CEST

Hello,

(I see we're topquoting here, so I'll stick to it.)

Guillaume and Michael. thanks for the tips.
I will try the GEF Plugin today,
I hope our stoff works.

Back to to Eclipse2.1 issue.

After Michael posted that it is working flawlessly under win32,
I looked at the plugin dir again.
I found that the subclipse-plugin 0.9 for Eclipse2.X has:

ssleay32.dll
svnClientAdapter.jar
svnjavahl.dll

but is missing:

libsvnjavahl.jnilib
libsvnjavahl.so

This prevents subclipse from working under linux.
I copied both files from my Eclipse3M7 plugins dir
to my bosses Eclipse2/plugins dir, and it worked instantly.

In my oppinon these files should be in the default package,
but maybe they are not because it says on the tigris.org page
that a linux port is being worked on.

I've been using subclipse (for 3M7) under linux for about 2 Months,
subclipse default (for 2.1) under linux seems to work
without problems also.

What has prevented the *.so files from being included in the main package?

Thanks to the developers,
you guys are doing a great job.

Bye from germany.

Huibert Alblas

> -----Ursprüngliche Nachricht-----
> Von: Guillaume Pothier [mailto:gpothier@free.fr]
> Gesendet: Montag, 3. Mai 2004 12:43
> An: users@subclipse.tigris.org
> Betreff: Re: Subclipse ecplise 2.1 and svn 1.0
>
>
> There are a lot of versions of GEF for Eclipse 3.0 (for instance that
> one is for M7:
> http://download.eclipse.org/tools/gef/downloads/drops/I-I20040
> 226-200402260005/index.php).
> I don't know about the stability.
> G.
>
> Alblas Huibert wrote:
>
> >Hello,
> >
> >I have sucsefuly convinced our team to switch from
> >PVCS to subversion. (hurray!)
> >
> >My colleagues and I are using Eclipse3M7
> >together with subversion 1.0.1 (runnnig win-nt4 and debian/testing)
> >without problems.
> >
> >My boss is stil unsing Eclipse 2.1 because
> >he develops some GEF based plugins.
> >GAF is not yet ported to Eclipse3.
> >
> >The problem is that I cannot get sublcipse to work
> >with eclipse 2.1.
> >I think the problems is that subclipse for Eclipse2
> >is linked against subversion 0.37,
> >but the subversion version used by my boss
> >is 1.0.1 (debian/testing)
> >
> >What should I do now?
> >
> >Can I install subversion 0.37 (where can I find the debs?)
> >and will this work with our rerpository (running subversion 1.0.2 on
> >debian/testin/unstable)
> >
> >Is there a change of getting subclipse for Eclipse2 linked
> against subverion
> >1.0X ?
> >
> >If someone could post some hints I could try to compile this myself,
> >but I don't know where to start.
> >
> >Thank in advance.
> >
> >
> >Mit freundlichen Grüßen / With kind regards
> >
> >Huibert Alblas
Received on Tue May 4 18:17:06 2004

This is an archived mail posted to the Subclipse Users mailing list.