[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: [Subclipse-dev] Subclipse "switch" very slow compared to "svn switch" (From users list)

From: Irving, Dave <dave.irving_at_logicacmg.com>
Date: 2006-04-10 18:30:59 CEST

> Then I did a right click, "Refresh" on the project - which took 5mins
> (with NO progress information other than "0%" progress until it
> completed).

Just to clarify, the next refresh performed after a switch of my project
root directory is the refresh which takes a very long time. It does not
matter whether this refresh occurs automatically (i.e, invoked by
SwitchToUrlCommand), or manually (i.e, with my changed
SwitchToUrlCommand, and a manual "refresh" after the switch).
Also, in both scenarios, the refresh has a dodgy progress monitor: No
progress is recorded until everything completes - it just sits on
"Building Workspace 0%" until it finally completes (not what ordinarily
happens with a "normal refresh").
Finally, this occurs even if no version controlled files are altered as
a result of the switch (although meta-data files will of course be
changed).

I'll try and investigate this further......

D

This e-mail and any attachment is for authorised use by the intended recipient(s) only. It may contain proprietary material, confidential information and/or be subject to legal privilege. It should not be copied, disclosed to, retained or used by, any other party. If you are not an intended recipient then please promptly delete this e-mail and any attachment and all copies and inform the sender. Thank you.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subclipse.tigris.org
For additional commands, e-mail: dev-help@subclipse.tigris.org
Received on Mon Apr 10 18:31:16 2006

This is an archived mail posted to the Subclipse Dev mailing list.