[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: subversion-1.9.12 tests successful on macOS

From: Branko Čibej <brane_at_apache.org>
Date: Mon, 22 Jul 2019 11:43:49 +0200

On 22.07.2019 11:26, Branko Čibej wrote:
> On 22.07.2019 10:02, Julian Foad wrote:
>> Julian Foad wrote:
>>> Nathan Hartman wrote:
>>>> I used get-deps.sh, but modified the zlib version to 1.2.11 and
>>>> download address to https://www.zlib.net/zlib-1.2.11.tar.gz because
>>>> it failed to get zlib.
>>>>
>>>> Summary of test results: [...]
>>>> Platform: macOS 10.13.6
>>> Thank you!
>>>
>>> I should have checked and updated get-deps.sh.
>> I just checked now. "./get_deps.sh zlib" works for me, fetching zlib
>> version 1.2.8, tested in svn 1.9.11 (which has the same get-deps.sh as
>> 1.9.12). Was it a temporary problem?
> [changed topic] Maybe we should upgrade that dependency? ISTR there was
> a vulnerability in ZLib that's fixed in newer versions?4

https://www.cvedetails.com/vulnerability-list/vendor_id-72/product_id-1820/year-2017/GNU-Zlib.html

(Why they call it "GNU" ZLib is beyond me.)

-- Brane
Received on 2019-07-22 11:43:53 CEST

This is an archived mail posted to the Subversion Dev mailing list.