Re: svn commit: r1755486 - in /subversion/trunk/subversion: include/svn_io.h libsvn_fs/fs-loader.c libsvn_repos/config_pool.c libsvn_subr/io.c libsvn_subr/stream.c tests/libsvn_fs/fs-test.c tests/libsvn_subr/stream-test.c
On 17 August 2016 at 19:23, Daniel Shahaf <d.s_at_daniel.shahaf.name> wrote:
> Ivan Zhakov wrote on Wed, Aug 17, 2016 at 19:09:53 +0300:
>> I've tried to improve docstring in r1756647.
> Looks great.
>> >> + * Use @a scratch_pool for temporary allocations and @a result_pool
>> >> + * to allocate @a *checksum.
>> >> + *
>> >> + * @since New in 1.10.
>> >> + */
>> >> +svn_error_t *
>> >> +svn_stream_checksum(svn_checksum_t **checksum,
>> > This interface seems very similar to svn_stream_checksummed(), both in
>> > name and in functionality.
>> I don't see problem here, but I could suggest name it as
>> svn_stream_contents_checksum(). What do you think?
> +1, that's harder to confuse with svn_stream_checksummed2() and
> analogous to svn_stream_contents_same2().
Done in r1756651. Thanks for review!
Received on 2016-08-17 18:38:03 CEST
This is an archived mail posted to the Subversion Dev