[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r1705060 - in /subversion/trunk/subversion/libsvn_ra_serf: ra_serf.h serf.c util.c

From: Stefan Sperling <stsp_at_elego.de>
Date: Thu, 24 Sep 2015 17:50:51 +0200

On Thu, Sep 24, 2015 at 05:40:45PM +0300, Ivan Zhakov wrote:
> On 24 September 2015 at 17:34, Bert Huijben <bert_at_qqmail.nl> wrote:
> >>
> >> +/* Parse a given URL_STR, fill in all supplied fields of URI
> >> + * structure.
> >> + *
> >> + * This function is a compatibility wrapper around apr_uri_parse().
> >> + * Different apr-util versions set apr_uri_t.path to either NULL or ""
> >> + * for root paths, and serf expects to see "/". This function always
> >> + * sets URI.path to "/" for these paths. */
> >> +svn_error_t *
> >> +svn_ra_serf__uri_parse(apr_uri_t *uri,
> >> + const char *url_str,
> >> + apr_pool_t *pool);
> >
> > I think the pool should be named result_pool here.
> >

+1

> I think we use POOL name if function accepts just one pool, and
> SCRATCH_POOL/RESULT_POOL in other case. Is not it?
>
> I would not mind to rename POOL to RESULT_POOL in this particular
> case, but I'm not sure that we should use RESULT_POOL in all other
> cases if function accepts one pool.

We certainly have functions that take only a scratch_pool.
The idea is to identify the purpose of the pool, and not only
in the case where there are 2 pools.
Received on 2015-09-24 17:51:10 CEST

This is an archived mail posted to the Subversion Dev mailing list.