[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r1705060 - in /subversion/trunk/subversion/libsvn_ra_serf: ra_serf.h serf.c util.c

From: Ivan Zhakov <ivan_at_visualsvn.com>
Date: Thu, 24 Sep 2015 17:40:45 +0300

On 24 September 2015 at 17:34, Bert Huijben <bert_at_qqmail.nl> wrote:
>> -----Original Message-----
>> From: ivan_at_apache.org [mailto:ivan_at_apache.org]
>> Sent: donderdag 24 september 2015 15:59
>> To: commits_at_subversion.apache.org
>> Subject: svn commit: r1705060 - in
>> /subversion/trunk/subversion/libsvn_ra_serf: ra_serf.h serf.c util.c
>>
>> Author: ivan
>> Date: Thu Sep 24 13:59:16 2015
>> New Revision: 1705060
>>
>> URL: http://svn.apache.org/viewvc?rev=1705060&view=rev
>> Log:
>> Refactor common code in ra_serf.
>>
>> * subversion/libsvn_ra_serf/ra_serf.h
>> (svn_ra_serf__uri_parse): New function declaration.
>>
>> * subversion/libsvn_ra_serf/util.c
>> (svn_ra_serf__uri_parse): New. Factored out from svn_ra_serf__open().
>>
>> * subversion/libsvn_ra_serf/serf.c
>> (svn_ra_serf__open, svn_ra_serf__reparent): Use
>> svn_ra_serf__uri_parse().
>>
>> Modified:
>> subversion/trunk/subversion/libsvn_ra_serf/ra_serf.h
>> subversion/trunk/subversion/libsvn_ra_serf/serf.c
>> subversion/trunk/subversion/libsvn_ra_serf/util.c
>>
>> Modified: subversion/trunk/subversion/libsvn_ra_serf/ra_serf.h
>> URL:
>> http://svn.apache.org/viewvc/subversion/trunk/subversion/libsvn_ra_serf/
>> ra_serf.h?rev=1705060&r1=1705059&r2=1705060&view=diff
>> ==========================================================
>> ====================
>> --- subversion/trunk/subversion/libsvn_ra_serf/ra_serf.h (original)
>> +++ subversion/trunk/subversion/libsvn_ra_serf/ra_serf.h Thu Sep 24
>> 13:59:16 2015
>> @@ -1548,6 +1548,17 @@ svn_ra_serf__create_bucket_with_eagain(c
>> apr_size_t len,
>> serf_bucket_alloc_t *allocator);
>>
>> +/* Parse a given URL_STR, fill in all supplied fields of URI
>> + * structure.
>> + *
>> + * This function is a compatibility wrapper around apr_uri_parse().
>> + * Different apr-util versions set apr_uri_t.path to either NULL or ""
>> + * for root paths, and serf expects to see "/". This function always
>> + * sets URI.path to "/" for these paths. */
>> +svn_error_t *
>> +svn_ra_serf__uri_parse(apr_uri_t *uri,
>> + const char *url_str,
>> + apr_pool_t *pool);
>
> I think the pool should be named result_pool here.
>
I think we use POOL name if function accepts just one pool, and
SCRATCH_POOL/RESULT_POOL in other case. Is not it?

I would not mind to rename POOL to RESULT_POOL in this particular
case, but I'm not sure that we should use RESULT_POOL in all other
cases if function accepts one pool.

-- 
Ivan Zhakov
Received on 2015-09-24 16:41:13 CEST

This is an archived mail posted to the Subversion Dev mailing list.