[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Invalid Makefile.PL generated if --enable-sqlite-compatibility-version specified

From: Ben Reser <ben_at_reser.org>
Date: Thu, 16 Jan 2014 21:05:31 -0800

On 1/16/14, 8:23 PM, James McCoy wrote:
> When --enable-sqlite-compatibility-version is used, the configure script
> ends up defining CFLAGS such that it contains
>
> -DSVN_SQLITE_MIN_VERSION='"X.Y.Z"'

...

> The attached patch fixes the issue for me.

Commited your patch in r1559009, backport nominated for 1.8.x.

Thanks, I couldn't think of a less ugly fix. We probably should do the same
for the rest of the autoconf replacements, though most of them are pretty
unlikely to have this sort of issue.
Received on 2014-01-17 06:04:21 CET

This is an archived mail posted to the Subversion Dev mailing list.