[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Error during 'svn export' over http with serf 1.3.1

From: Johan Corveleyn <jcorvel_at_gmail.com>
Date: Sat, 24 Aug 2013 21:20:00 +0200

On Sat, Aug 24, 2013 at 1:21 PM, Ivan Zhakov <ivan_at_visualsvn.com> wrote:
> On Sat, Aug 24, 2013 at 3:19 PM, Ivan Zhakov <ivan_at_visualsvn.com> wrote:
>> Thanks! I'll check it later today. Btw did you try fully uninstall antivirus?
>>

No, I didn't try that yet. I'm afraid I'll lose the ability to
reproduce this issue :-). But okay, I might give that a try later (and
then reinstall it back to continue the investigation).

> Johan, could I also try to disable compression using --config-option
> servers:global:http-compression=off command line option and provide
> debug logs. Thank you.
>

Okay, just tried with compression disabled, but I haven't been able to
reproduce it that way. I tried the export 10 times or so, without a
problem.

After that, I switched compression back on, and also found that it was
somehow harder to reproduce (had to try 4 times or so, before I hit an
error). Perhaps some condition related to timing changed slightly.

For some reason, I also sometimes got another error:
[[[
..\..\..\subversion\svn\export-cmd.c:127,
..\..\..\subversion\libsvn_client\export.c:1441,
..\..\..\subversion\libsvn_client\export.c:1334,
..\..\..\subversion\libsvn_ra_serf\update.c:2981: (apr_err=120105)
svn: E120105: Error retrieving REPORT: The server sent an improper HTTP response
]]]

Will try again now a bit with compression disabled.

-- 
Johan
Received on 2013-08-24 21:20:52 CEST

This is an archived mail posted to the Subversion Dev mailing list.