[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Error during 'svn export' over http with serf 1.3.1

From: Lieven Govaerts <lieven.govaerts_at_gmail.com>
Date: Sat, 24 Aug 2013 21:17:26 +0200

On Sat, Aug 24, 2013 at 12:03 PM, Johan Corveleyn <jcorvel_at_gmail.com> wrote:

> On Sat, Aug 24, 2013 at 11:13 AM, Ivan Zhakov <ivan_at_visualsvn.com> wrote:
> > On Saturday, August 24, 2013, Johan Corveleyn wrote:
> >>
> >> On Sat, Aug 24, 2013 at 10:17 AM, Johan Corveleyn <jcorvel_at_gmail.com>
> >> wrote:
> >> > On Sat, Aug 24, 2013 at 6:20 AM, Ivan Zhakov <ivan_at_visualsvn.com>
> wrote:
> >> >> On Sat, Aug 24, 2013 at 1:51 AM, Johan Corveleyn <jcorvel_at_gmail.com>
> >> >> wrote:
> >> >>> I get an error when exporting
> >> >>> http://svn.apache.org/repos/asf/subversion/tags/1.8.3, with
> trunk_at_now
> >> >>> + serf 1.3.1:
> >> >>>
> >> >>> [[[
> >> >>> svn export -q http://svn.apache.org/repos/asf/subversion/tags/1.8.3
> >> >>> ..\..\..\subversion\svn\export-cmd.c:127,
> >> >>> ..\..\..\subversion\libsvn_client\export.c:1441,
> >> >>> ..\..\..\subversion\libsvn_client\export.c:1334,
> >> >>> ..\..\..\subversion\libsvn_ra_serf\update.c:2978,
> >> >>> ..\..\..\subversion\libsvn_ra_serf\util.c:2186,
> >> >>> ..\..\..\subversion\libsvn_ra_serf\util.c:2167,
> >> >>> ..\..\..\subversion\libsvn_ra_serf\update.c:1147: (apr_err=120104)
> >> >>> svn: E120104: ra_serf: An error occurred during decompression
> >> >>> ]]]
> >> >>>
> >> >>> It doesn't happen always, but say 8 times out of 10 (in different
> >> >>> places during the export).
> >> >>>
> >> >>> I haven't been able to reproduce it with serf 1.2.1, nor with serf
> >> >>> 1.3.1 via https. Only with serf 1.3.1 exporting from http.
> >> >>>
> >> >> Do you have antivirus software installed?
> >> >
> >> > Yes (AVG antivirus free edition), but if I disable it, the error still
> >> > happens.
> >> > Running on Windows XP.
> >> >
> >> >> Could you provide serf debug logs?
> >>
> >> This is what I get with "#define SOCK_VERBOSE 1" and "#define
> CONN_VERBOSE
> >> 1":
> >>
> >> [[[
> >> C:\Temp\test>svn export -q
> >> http://svn.apache.org/repos/asf/subversion/tags/1.8.3 5
> >> [2013-08-24T10:37:23.921875+02] outgoing.c: created connection 0x12bb8f8
> >> [2013-08-24T10:37:23.937500+02] outgoing.c: created socket for conn
> >> 0x12bb8f8, status 0
> >> [2013-08-24T10:37:23.937500+02] [l:0.0.0.0:0 r:160.45.251.2:80]
> >> outgoing.c: connected socket for conn 0x12bb8f8, status
> >> 730036
> >> [2013-08-24T10:37:24.203125+02] outgoing.c: created connection 0x12bc020
> >> [2013-08-24T10:37:24.703125+02] outgoing.c: created connection 0x12d83b0
> >> [2013-08-24T10:37:24.718750+02] outgoing.c: created socket for conn
> >> 0x12bc020, status 0
> >> [2013-08-24T10:37:24.718750+02] [l:0.0.0.0:0 r:160.45.251.2:80]
> >> outgoing.c: connected socket for conn 0x12bc020, status
> >> 730036
> >> [2013-08-24T10:37:24.937500+02] outgoing.c: created connection 0x12d8660
> >> [2013-08-24T10:37:25.250000+02] outgoing.c: created socket for conn
> >> 0x12d83b0, status 0
> >> [2013-08-24T10:37:25.578125+02] [l:0.0.0.0:0 r:160.45.251.2:80]
> >> outgoing.c: connected socket for conn 0x12d83b0, status
> >> 730036
> >> [2013-08-24T10:37:26.921875+02] outgoing.c: created socket for conn
> >> 0x12d8660, status 0
> >> [2013-08-24T10:37:27.015625+02] [l:0.0.0.0:0 r:160.45.251.2:80]
> >> outgoing.c: connected socket for conn 0x12d8660, status
> >> 730036
> >> ..\..\..\subversion\svn\export-cmd.c:127,
> >> ..\..\..\subversion\libsvn_client\export.c:1441,
> >> ..\..\..\subversion\libsvn_client\export.c:1334,
> >> ..\..\..\subversion\libsvn_ra_serf\update.c:2978,
> >> ..\..\..\subversion\libsvn_ra_serf\util.c:2186,
> >> ..\..\..\subversion\libsvn_ra_serf\util.c:2167,
> >> ..\..\..\subversion\libsvn_ra_serf\update.c:1147: (apr_err=120104)
> >> svn: E120104: ra_serf: An error occurred during decompression
> >> [2013-08-24T10:37:58.468750+02] [l:0.0.0.0:0 r:160.45.251.2:80]
> >> outgoing.c: cleanup - closed socket, status 0
> >> [2013-08-24T10:37:58.484375+02] [l:0.0.0.0:0 r:160.45.251.2:80]
> >> outgoing.c: cleanup - closed socket, status 0
> >> [2013-08-24T10:37:58.500000+02] [l:0.0.0.0:0 r:160.45.251.2:80]
> >> outgoing.c: cleanup - closed socket, status 0
> >> [2013-08-24T10:37:58.515625+02] [l:0.0.0.0:0 r:160.45.251.2:80]
> >> outgoing.c: cleanup - closed socket, status 0
> >> [2013-08-24T10:37:58.531250+02] outgoing.c: cleaning up connection
> >> 0x12d8660
> >> [2013-08-24T10:37:58.531250+02] outgoing.c: closed connection 0x12d8660
> >> [2013-08-24T10:37:58.546875+02] outgoing.c: cleaning up connection
> >> 0x12d83b0
> >> [2013-08-24T10:37:58.546875+02] outgoing.c: closed connection 0x12d83b0
> >> [2013-08-24T10:37:58.562500+02] outgoing.c: cleaning up connection
> >> 0x12bc020
> >> [2013-08-24T10:37:58.578125+02] outgoing.c: closed connection 0x12bc020
> >> [2013-08-24T10:37:58.578125+02] outgoing.c: cleaning up connection
> >> 0x12bb8f8
> >> [2013-08-24T10:37:58.593750+02] outgoing.c: closed connection 0x12bb8f8
> >> ]]]
> >>
> >> I don't know if that's useful. Maybe I need to enable some other debug
> >> flags to get more?
> >
> > You need enable sock_msg_verbose to see what data sent and recieved.
> >
>

SOCK_MSG_VERBOSE makes serf dump the raw bytes received from/sent to the
network, so that only works for unencoded data. SSL or in this case
deflate-encoded data can not be analysed with this flag.

Can you provide us with a wireshark (or ...) pcap file?
thanks,
Lieven

> See attachment.
>
> --
> Johan
>
Received on 2013-08-24 21:18:23 CEST

This is an archived mail posted to the Subversion Dev mailing list.