[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Error compiling with serf 1.3.1 on Windows

From: Johan Corveleyn <jcorvel_at_gmail.com>
Date: Mon, 19 Aug 2013 22:39:45 +0200

When I try to build trunk (@now) with serf 1.3.1 on Win XP (with VS
2010), I get the following error:

[[[
NMAKE : fatal error U1052: file 'serf.mak' not found
[C:\research\svn\client_build\svn_deps\serf-1.3.1\serf.vcxproj]
C:\Program Files\MSBuild\Microsoft.Cpp\v4.0\Microsoft.MakeFile.Targets(38,5):
error MSB3073: The command ""c:\Program Files\Microsoft Visual Studio
10.0\VC\bin\nmake.exe" /s /nologo /f serf.mak ALL
APR_SRC=..\httpd-2.4.4\srclib\apr
APRUTIL_SRC=..\httpd-2.4.4\srclib\apr-util ZLIB_SRC=..\zlib-1.2.8
OPENSSL_SRC=..\openssl-1.0.1e " exited with code 2.
[C:\research\svn\client_build\svn_deps\serf-1.3.1\serf.vcxproj]
]]]

Is anyone else seeing this? Perhaps something needs to be updated in
gen-make.py since the new serf?

This is the gen-make.py command I used:
[[[
python gen-make.py --release
--with-junit=C:\research\svn\client_build\svn_deps\junit-4.10\junit.jar
--with-httpd=C:\research\svn\client_build\svn_deps\httpd-2.4.4
--with-serf=C:\research\svn\client_build\svn_deps\serf-1.3.1
--with-openssl=C:\research\svn\client_build\svn_deps\openssl-1.0.1e
--with-sqlite=C:\research\svn\client_build\svn_deps\sqlite-amalgamation-3.7.17
--enable-ml --with-zlib=C:\research\svn\client_build\svn_deps\zlib-1.2.8
--vsnet-version=2010 -t vcproj
]]]

Building with serf 1.2.1 still works fine for me.

-- 
Johan
Received on 2013-08-19 22:40:38 CEST

This is an archived mail posted to the Subversion Dev mailing list.