[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Log messages Re: svn commit: r1505729 - /subversion/branches/fsfs-improvements/subversion/libsvn_fs_fs/cache d_data.c

From: Stefan Fuhrmann <stefan.fuhrmann_at_wandisco.com>
Date: Sun, 4 Aug 2013 12:50:59 +0200

On Sun, Aug 4, 2013 at 8:32 AM, Daniel Shahaf <danielsh_at_elego.de> wrote:

> stefan2_at_apache.org wrote on Mon, Jul 22, 2013 at 16:49:25 -0000:
> > Author: stefan2
> > Date: Mon Jul 22 16:49:24 2013
> > New Revision: 1505729
> >
> > URL: http://svn.apache.org/r1505729
> > Log:
> > On the fsfs-improvements branch: Rename a debug function.
> >
> > * subversion/libsvn_fs_fs/cached_data.c
> > (dgb__log_access): rename to ...
> > (dbg_log_access): ... this one
>
> That's a classic example of a log message that leaves me "Huh?"-ed: it
> says nothing more than the unidiff says. "Fix a typo in the function
> name" would have been easier to understand.
>

Agreed and changed.

> This one is a trivial patch, but the point of "Describe the why, not the
> what" applies to larger, less-trivial patches too. (And that's why
> I made it)
>

I agree with the general goal. Changes that don't impact functionality,
however, often could be summarized as "shuffle code around" and I
find it hard to express the rationale behind those. Of course, there is
a "why" behind them but that can usually be paraphrased as "because
it's just better / nicer that way". On example:

r1506344
On the fsfs-improvements branch: refactor some ID allocation code
into shared functions.

-- Stefan^2,
Received on 2013-08-04 12:51:38 CEST

This is an archived mail posted to the Subversion Dev mailing list.