Re: svn commit: r1502964 - in /subversion/branches/fsfs-improvements/subversion/libsvn_fs_fs: fs_fs.c fs_fs.h lock.c pack.c util.c util.h
On Sun, Aug 04, 2013 at 08:51:02AM +0300, Daniel Shahaf wrote:
> stefan2_at_apache.org wrote on Sun, Jul 14, 2013 at 12:34:50 -0000:
> > Author: stefan2
> > Date: Sun Jul 14 12:34:49 2013
> > New Revision: 1502964
> > URL: http://svn.apache.org/r1502964
> > Log:
> > On the fsfs-improvements branch: Move more of the commonly used file and
> > path utilities from fs_fs.* to utils.*. Again, we add the svn_fs_fs__
> > prefix to everything in utils.h.
> > Also make all path getters that didn't do so before return a const char*
> > instead of an svn_error_t *.
> Can you please refrain from moving a function around (intra-file or
> inter-file) while changing its signature or implementation. That makes
> review harder than it should be.
Specifically, commits that move a function *and* change its semantics
require me to review the change by copy-pasting a function definition
prefixed by '-' signs to a temp buffer and then eyeball-diffing that
definition against one prefixed by '+' signs in my MUA.
Received on 2013-08-04 08:04:30 CEST
This is an archived mail posted to the Subversion Dev