[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Dependency versioning question

From: Greg Stein <gstein_at_gmail.com>
Date: Wed, 5 Jun 2013 19:50:58 -0400

Hey all,

I've got a question where I'm not quite sure what the answer "should"
be. While I wrote the rules on versioning components, it never talked
about cross-component and dependency versioning. For Subversion, we
said "all svn components should be at the same version".

But dependencies.

Within serf, we're thinking about new models for connection and
protocol handling. And bumping to 2.0 to make that happen. What is the
effect upon libsvn_ra_serf and svn in general?

My thinking is "no big deal". That upgrading to svn 1.9 (or 1.10 or
whatever) would require installation of serf 2.0. All svn APIs would
remain unchanged, per our own versioning guidelines (both source and
binary APIs).

Thoughts?

Cheers,
-g
Received on 2013-06-06 01:51:31 CEST

This is an archived mail posted to the Subversion Dev mailing list.