[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 1.7.x and Ruby 1.9

From: Philip Martin <philip.martin_at_wandisco.com>
Date: Thu, 30 May 2013 17:31:00 +0100

Ben Reser <ben_at_reser.org> writes:

> Has anyone considered backporting the Ruby 1.9 compatability to the 1.7.x line?
>
> We've got distros shipping with Ruby 1.9 now (e.g. OpenSUSE 12.2) and
> not being able to build/use the Ruby bindings without upgrading to 1.8
> seems like a pain.
>
> I don't know enough Ruby myself to know if we can safely do this to 1.7.x.

I can confirm that r1407206, which introduced the Ruby 1.9 support,
applies cleanly to 1.7.x and 'make check-swig-rb' then passes on my
Debian box with ruby1.9.1-dev installed. (Ruby versioning is
complicated: the package name is ruby1.9.1 but the version is
1.9.3.194-8.1.)

-- 
Certified & Supported Apache Subversion Downloads:
http://www.wandisco.com/subversion/download
Received on 2013-05-30 18:31:35 CEST

This is an archived mail posted to the Subversion Dev mailing list.