[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Windows build still requires apr-util?

From: Branko Čibej <brane_at_wandisco.com>
Date: Wed, 13 Mar 2013 14:59:15 +0100

On 13.03.2013 13:08, Bert Huijben wrote:
>> -----Original Message-----
>> From: Sergei Antonov [mailto:saproj_at_gmail.com]
>> Sent: zondag 10 maart 2013 16:39
>> To: dev_at_subversion.apache.org
>> Subject: Re: Windows build still requires apr-util?
>>
>> Well, I took apr-util-1.5.1-win32-src.zip and dsw/dsp were generated.
>> Then I opened .dsw in VS 2010, did a conversion, and tried to build.
>> Nothing except zlib compiles, with a lot of "Cannot open include file:
>> 'svn_private_config.h'" errors. Did I miss some step that generates
>> this file?
> I can confirm that the build with Visual C++ 6.0 scripts is broken on trunk since r1371633, but I currently don't have access to that version of Visual C++ to fix it.

Nor should you even try to, IMO. There comes a time when it ceases to
make any sense to support an old compiler that's been EOL-d a while ago,
especially since free versions of newer compilers are available.

I would support removing the .dsp generator completely.

-- Brane

-- 
Branko Čibej
Director of Subversion | WANdisco | www.wandisco.com
Received on 2013-03-13 14:59:57 CET

This is an archived mail posted to the Subversion Dev mailing list.