[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: OT: $SVN envvars Re: svn 1.8 debugging-compilation-serf-configure problem because of 1.6 Ubuntu install

From: Gabriela Gibson <gabriela.gibson_at_gmail.com>
Date: Mon, 04 Mar 2013 23:16:21 +0000

On 04/03/13 22:57, Daniel Shahaf wrote:
> Gabriela Gibson wrote on Mon, Mar 04, 2013 at 22:33:23 +0000:

>> What I've also found during my experiments at the weekend is that
>> apr-related entries in LD_FLAGS are edited while configure runs. So:
>>
>> LD_FLAGS="-L/usr/local/serf/lib -L/usr/local/apr/lib" ./configure \
>> --enable-maintainer-mode --with-serf=/usr/local/serf
>>
>> failed. Examining config.log showed that the failure appeared to occur
>> in the link test, and that the entry for "-L/usr/local/apr/lib" has been
>> removed.
>>
>
> Which link test was it? It's hard to make any comment about the
> situation without seeing the code and the reason it strips -L flags.
> (Is that our code, or something in autoconf's m4 library, that strips
> the -L flags?)
Since there is interest in the config.log:

LD_FLAGS="-L/usr/local/apr -L/foo/bar/baz" ./configure
--with-serf=/usr/local/serf --enable-maintainer-mode

configure:5535: gcc -o conftest -g -O2 -g -O2 -Wall
-Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -pthread
   -\
D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE
-I/home/g/trunk3/apr/include -I/home/g/trunk3/apr-util/include
-I/usr/local/s\
erf/include/serf-1 -L/usr/local/serf/lib conftest.c -lserf-1
-L/home/g/trunk3/apr-util -laprutil-1 -L/home/g/trunk3/apr -lapr-\
1 -lz >&5
conftest.c:28:1: warning: function declaration isn't a prototype
[-Wstrict-prototypes]
conftest.c:30:1: warning: function declaration isn't a prototype
[-Wstrict-prototypes]
/usr/bin/ld: cannot find -laprutil-1
/usr/bin/ld: cannot find -lapr-1
collect2: ld returned 1 exit status
Received on 2013-03-05 00:16:42 CET

This is an archived mail posted to the Subversion Dev mailing list.