Re: Combine and rename WC APIs that check WC root and switched
From: Julian Foad <julianfoad_at_btopenworld.com>
Date: Wed, 5 Dec 2012 15:25:20 +0000 (GMT)
Bert Huijben wrote:
> Why create such a long function name?
My specific points are:
† * We have two current names (1) and (3) for exactly the same functionality.
So I'm going to make the two names the same (modulo the '__db' part), and I'm going to make them in some way reflect that checking for a 'root' is part of their functionality.† Ideally I'd like the name to reflect that they do more than that.† The word 'check' is a rather weak cue for that, but it already exists and I want a simple acceptable solution.
So, I'll stick with the name 'check_root' and just change (3) to match it, so we'll have:
† 1) svn_wc_check_root(*is_wcroot,*is_switched,*kind,...)
† 5) svn_wc__is_wcroot(*is_wcroot,...)
This is an archived mail posted to the Subversion Dev mailing list.