RE: Combine and rename WC APIs that check WC root and switched
From: Bert Huijben <bert_at_qqmail.nl>
Date: Wed, 5 Dec 2012 13:28:27 +0100
> -----Original Message-----
I don't see a real problem with a function that checks for several kinds of root, and returns different answers that allows you to determine what a root is for you.
Why create such a long function name?
I'm not sure if it tells more than the current name, and it is not complete either.
svn_wc_check_wcroot_switched_and_kind(), would be complete but I don't think it really adds something; the usage of the separate optional output arguments already tells that you know what the function does.
PS. If we want to crash the compilers and break the 80 character linewidth we can also rename svn_wc__db_read_read info to show all its arguments in its name ;-)
This is an archived mail posted to the Subversion Dev mailing list.