[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] enabling ruby in the subversion build

From: Michael Chletsos <mpchlets_at_gmail.com>
Date: Wed, 7 Nov 2012 05:38:45 -1000

I would support 1.9.3 - ruby 1.9.2 and 1.9.1 are not considered good
versions and are problematic.

The current patch I used does not fix the configure script, I could
modify that to only use <= 1.8.7 or >= 1.9.3 if you like.

On Wed, Nov 7, 2012 at 5:31 AM, Philip Martin
<philip.martin_at_wandisco.com> wrote:
> Michael Chletsos <mpchlets_at_gmail.com> writes:
>
>> OK - first, I would not support ruby 1.9.1 - I assume that you really
>> have 1.9.2 (debian/ubuntu uses a meta-package)- can you show me the
>> output of ruby -v
>>
>> I would support ruby 1.9.3 and above - there were issues with 1.9.1 and 1.9.2.
>
> I used whatever was part of Debian stable:
>
> ii ruby1.9.1 1.9.2.0-2 Interpreter of object-oriented scripting lan
>
> If 1.9.1 and 1.9.2 are not supported then the patch has to be modified
> to refuse to accpet them. According to the package:
>
> Ruby uses two parallel versioning schemes: the `Ruby library compatibility
> version' (1.9.1 for this package), which is similar to a library SONAME, and
> the `Ruby version' (1.9.3 for this package).
>
> Which versions should we support?
>
> --
> Certified & Supported Apache Subversion Downloads:
> http://www.wandisco.com/subversion/download
Received on 2012-11-07 16:39:20 CET

This is an archived mail posted to the Subversion Dev mailing list.