[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] enabling ruby in the subversion build

From: Philip Martin <philip.martin_at_wandisco.com>
Date: Wed, 07 Nov 2012 15:31:14 +0000

Michael Chletsos <mpchlets_at_gmail.com> writes:

> OK - first, I would not support ruby 1.9.1 - I assume that you really
> have 1.9.2 (debian/ubuntu uses a meta-package)- can you show me the
> output of ruby -v
> I would support ruby 1.9.3 and above - there were issues with 1.9.1 and 1.9.2.

I used whatever was part of Debian stable:

ii ruby1.9.1 Interpreter of object-oriented scripting lan

If 1.9.1 and 1.9.2 are not supported then the patch has to be modified
to refuse to accpet them. According to the package:

 Ruby uses two parallel versioning schemes: the `Ruby library compatibility
 version' (1.9.1 for this package), which is similar to a library SONAME, and
 the `Ruby version' (1.9.3 for this package).

Which versions should we support?

Certified & Supported Apache Subversion Downloads:
Received on 2012-11-07 16:31:52 CET

This is an archived mail posted to the Subversion Dev mailing list.