[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] Make Python 2.5 minimum version for dev tools (including test suite)

From: Hyrum K Wright <hyrum.wright_at_wandisco.com>
Date: Thu, 9 Feb 2012 16:27:39 -0600

On Thu, Feb 9, 2012 at 4:10 PM, Daniel Shahaf <danielsh_at_elego.de> wrote:
> Hyrum K Wright wrote on Thu, Feb 09, 2012 at 16:04:06 -0600:
>> I find myself wanting to use the 'with' statement in the test suite,
>> which was introduced in Python 2.5  Python 2.5 was released 5.5 years
>> ago, and while I'm sure somebody on some archaic platform somewhere
>> doesn't have it installed, I think we can reasonably assume that
>> Python 2.5 is generally available.  For reference, we currently
>> require and SQLite that is only 2.5-years-old.
>>
>
> We require SQLite 3.6.18 because it contains a bug fix we need, not
> because we think it's "old enough".
>
> http://www.sqlite.org/releaselog/3_6_18.html

Certainly. The primary point was that if somebody wants to build
Subversion (and ostensibly test it) their distro has to have software
from at least 2009, so it doesn't make much sense that our Python
dependency is still rooted in 2006.

-Hyrum

>> (And for the historically minded among us, let's please don't repeat
>> the same bikeshed we had when we bumped to Python 2.4 3 years ago:
>> http://svn.haxx.se/dev/archive-2009-01/0266.shtml)
>>
>> I would like to recommend we bump our minimum required version for the
>> test suite and development tools to Python 2.5.
>>
>> Thoughts?
>>
>> -Hyrum
>>
>>
>> --
>>
>> uberSVN: Apache Subversion Made Easy
>> http://www.uberSVN.com/

-- 
uberSVN: Apache Subversion Made Easy
http://www.uberSVN.com/
Received on 2012-02-09 23:28:11 CET

This is an archived mail posted to the Subversion Dev mailing list.