[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] Make Python 2.5 minimum version for dev tools (including test suite)

From: Peter Samuelson <peter_at_p12n.org>
Date: Thu, 9 Feb 2012 16:16:03 -0600

[Hyrum K Wright]
> I think we can reasonably assume that Python 2.5 is generally
> available. For reference, we currently require and SQLite that is
> only 2.5-years-old.

Obligatory "what about Debian users, since that platform is always so
far behind": the oldest supported Debian release, lenny, has Python
2.5.2. In about a month we'll stop supporting that, then the oldest
python supported by Debian will be 2.6.6, in squeeze.

(Technically, squeeze still ships 2.5, but /usr/bin/python is 2.6.)

So, +1. Nobody needs to build Subversion on a platform older than
Debian's oldest supported release. (:
Received on 2012-02-09 23:16:49 CET

This is an archived mail posted to the Subversion Dev mailing list.