[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] enabling ruby in the subversion build

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Mon, 19 Dec 2011 18:28:55 +0200

Stefan Sperling wrote on Mon, Dec 19, 2011 at 11:46:14 +0100:
> On Mon, Dec 19, 2011 at 10:04:55AM +0200, Daniel Shahaf wrote:
> > On Sun, Dec 18, 2011, at 18:37, Vincent Batts wrote:
> > > I will start by working on all of the 'E' errors in the ruby tests
> > > straight. I primarily want to see these ruby bindings back into the main
> > > bundle of bindings, now that many distributions are defaulting to ruby
> > > 1.9.x. Arch linux has followed upstream suite and shipped a subversion
> > > without ruby bindings.
> > >
> > > Should I send a separate patch, or amend the previous?
> >
> > Please don't send interdiffs; but send patches against trunk_at_HEAD.
> >
> > Please send separate patches for separate functional changes. Getting
> > the tests to pass with ruby1.8 would be a separate functional change than
> > supporting ruby1.9.
>
> The tests are passing for me locally with ruby 1.8.
> I would suspect some local problem at Vincent's side is preventing them
> from passing.

Could be either a local build problem on Vincent's side or a bug in the
testsuite causing it to fail in Vincent's environment; and in the latter
case we'd appreciate a patch.
Received on 2011-12-19 17:29:39 CET

This is an archived mail posted to the Subversion Dev mailing list.