[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: svn_error_t *make_foo(svn_foo_t **foo_p, apr_pool_t *result, apr_pool_t *scratch);

From: Bert Huijben <bert_at_qqmail.nl>
Date: Tue, 13 Sep 2011 16:07:33 +0200

> -----Original Message-----
> From: C. Michael Pilato [mailto:cmpilato_at_collab.net]
> Sent: dinsdag 13 september 2011 16:02
> To: Daniel Shahaf
> Cc: dev_at_subversion.apache.org
> Subject: Re: svn_error_t *make_foo(svn_foo_t **foo_p, apr_pool_t
> *result, apr_pool_t *scratch);
>
> On 09/12/2011 09:12 PM, Daniel Shahaf wrote:
> > [RFC] In new code, rename RESULT_POOL and SCRATCH_POOL to RESULT
> and
> > SCRATCH, respectively.
> >
> > Because the names are too long and C is strongly typed.
>
> Meh.
>
> Or, to be more formal about it: -0.

-0 too.

I think it hurts readability of patches.

        Bert
Received on 2011-09-13 16:07:54 CEST

This is an archived mail posted to the Subversion Dev mailing list.